To receive notifications about scheduled maintenance, please subscribe to the mailing-list gitlab-operations@sympa.ethz.ch. You can subscribe to the mailing-list at https://sympa.ethz.ch

Commit 24a18d0c authored by matthmey's avatar matthmey
Browse files

Delete poetry.lock

parent b22376df
[[package]]
category = "main"
description = "A small Python module for determining appropriate platform-specific dirs, e.g. a \"user data dir\"."
name = "appdirs"
optional = false
python-versions = "*"
version = "1.4.3"
[[package]]
category = "main"
description = "Draws ASCII trees."
name = "asciitree"
optional = false
python-versions = "*"
version = "0.3.3"
[[package]]
category = "dev"
description = "Atomic file writes."
name = "atomicwrites"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "1.3.0"
[[package]]
category = "main"
description = "Classes Without Boilerplate"
name = "attrs"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "19.3.0"
[package.extras]
azure-pipelines = ["coverage", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "zope.interface", "pytest-azurepipelines"]
dev = ["coverage", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "zope.interface", "sphinx", "pre-commit"]
docs = ["sphinx", "zope.interface"]
tests = ["coverage", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "zope.interface"]
[[package]]
category = "main"
description = "The uncompromising code formatter."
name = "black"
optional = false
python-versions = ">=3.6"
version = "19.10b0"
[package.dependencies]
appdirs = "*"
attrs = ">=18.1.0"
click = ">=6.5"
pathspec = ">=0.6,<1"
regex = "*"
toml = ">=0.9.4"
typed-ast = ">=1.4.0"
[package.extras]
d = ["aiohttp (>=3.3.2)", "aiohttp-cors"]
[[package]]
category = "main"
description = "Interactive plots and applications in the browser from Python"
marker = "extra == \"complete\""
name = "bokeh"
optional = false
python-versions = "*"
version = "1.4.0"
[package.dependencies]
Jinja2 = ">=2.7"
PyYAML = ">=3.10"
numpy = ">=1.7.1"
packaging = ">=16.8"
pillow = ">=4.0"
python-dateutil = ">=2.1"
six = ">=1.5.2"
tornado = ">=4.3"
[[package]]
category = "main"
description = "Python package for providing Mozilla's CA Bundle."
name = "certifi"
optional = false
python-versions = "*"
version = "2019.9.11"
[[package]]
category = "main"
description = "Universal encoding detector for Python 2 and 3"
name = "chardet"
optional = false
python-versions = "*"
version = "3.0.4"
[[package]]
category = "main"
description = "Composable command line interface toolkit"
name = "click"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "7.0"
[[package]]
category = "main"
description = "Extended pickling support for Python objects"
name = "cloudpickle"
optional = false
python-versions = "*"
version = "1.2.2"
[[package]]
category = "dev"
description = "Cross-platform colored terminal text."
marker = "sys_platform == \"win32\""
name = "colorama"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "0.4.1"
[[package]]
category = "dev"
description = "Code coverage measurement for Python"
name = "coverage"
optional = false
python-versions = ">=2.6, !=3.0.*, !=3.1.*, !=3.2.*, <4"
version = "4.5.4"
[[package]]
category = "main"
description = "Composable style cycles"
name = "cycler"
optional = false
python-versions = "*"
version = "0.10.0"
[package.dependencies]
six = "*"
[[package]]
category = "main"
description = "Parallel PyData with Task Scheduling"
name = "dask"
optional = false
python-versions = ">=3.6"
version = "2.8.1"
[package.dependencies]
[package.dependencies.PyYaml]
optional = true
version = "*"
[package.dependencies.bokeh]
optional = true
version = ">=1.0.0"
[package.dependencies.cloudpickle]
optional = true
version = ">=0.2.1"
[package.dependencies.distributed]
optional = true
version = ">=2.0"
[package.dependencies.fsspec]
optional = true
version = ">=0.6.0"
[package.dependencies.numpy]
optional = true
version = ">=1.13.0"
[package.dependencies.pandas]
optional = true
version = ">=0.21.0"
[package.dependencies.partd]
optional = true
version = ">=0.3.10"
[package.dependencies.toolz]
optional = true
version = ">=0.7.3"
[package.extras]
array = ["numpy (>=1.13.0)", "toolz (>=0.7.3)"]
bag = ["cloudpickle (>=0.2.1)", "fsspec (>=0.6.0)", "toolz (>=0.7.3)", "partd (>=0.3.10)"]
complete = ["pyyaml", "bokeh (>=1.0.0)", "cloudpickle (>=0.2.1)", "distributed (>=2.0)", "fsspec (>=0.6.0)", "numpy (>=1.13.0)", "pandas (>=0.21.0)", "partd (>=0.3.10)", "toolz (>=0.7.3)"]
dataframe = ["numpy (>=1.13.0)", "pandas (>=0.21.0)", "toolz (>=0.7.3)", "partd (>=0.3.10)", "fsspec (>=0.6.0)"]
delayed = ["cloudpickle (>=0.2.1)", "toolz (>=0.7.3)"]
diagnostics = ["bokeh (>=1.0.0)"]
distributed = ["distributed (>=2.0)"]
[[package]]
category = "main"
description = "Decorators for Humans"
name = "decorator"
optional = false
python-versions = ">=2.6, !=3.0.*, !=3.1.*"
version = "4.4.1"
[[package]]
category = "main"
description = "Distributed scheduler for Dask"
marker = "extra == \"complete\""
name = "distributed"
optional = false
python-versions = ">=3.6"
version = "2.8.1"
[package.dependencies]
click = ">=6.6"
cloudpickle = ">=0.2.2"
dask = ">=2.7.0"
msgpack = "*"
psutil = ">=5.0"
pyyaml = "*"
sortedcontainers = "<2.0.0 || >2.0.0,<2.0.1 || >2.0.1"
tblib = "*"
toolz = ">=0.7.4"
tornado = ">=5"
zict = ">=0.1.3"
[[package]]
category = "dev"
description = "Discover and load entry points from installed packages."
name = "entrypoints"
optional = false
python-versions = ">=2.7"
version = "0.3"
[[package]]
category = "main"
description = "A python package that provides useful locks."
name = "fasteners"
optional = false
python-versions = "*"
version = "0.15"
[package.dependencies]
monotonic = ">=0.1"
six = "*"
[[package]]
category = "dev"
description = "the modular source code checker: pep8, pyflakes and co"
name = "flake8"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "3.7.9"
[package.dependencies]
entrypoints = ">=0.3.0,<0.4.0"
mccabe = ">=0.6.0,<0.7.0"
pycodestyle = ">=2.5.0,<2.6.0"
pyflakes = ">=2.1.0,<2.2.0"
[[package]]
category = "main"
description = "File-system specification"
marker = "extra == \"complete\""
name = "fsspec"
optional = false
python-versions = ">=3.5"
version = "0.6.0"
[[package]]
category = "main"
description = "Clean single-source support for Python 3 and 2"
name = "future"
optional = false
python-versions = ">=2.6, !=3.0.*, !=3.1.*, !=3.2.*"
version = "0.18.2"
[[package]]
category = "main"
description = "a heap with decrease-key and increase-key operations"
marker = "extra == \"complete\""
name = "heapdict"
optional = false
python-versions = "*"
version = "1.0.1"
[[package]]
category = "main"
description = "Internationalized Domain Names in Applications (IDNA)"
name = "idna"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "2.8"
[[package]]
category = "dev"
description = "Read metadata from Python packages"
marker = "python_version < \"3.8\""
name = "importlib-metadata"
optional = false
python-versions = ">=2.7,!=3.0,!=3.1,!=3.2,!=3.3"
version = "0.23"
[package.dependencies]
zipp = ">=0.5"
[package.extras]
docs = ["sphinx", "rst.linker"]
testing = ["packaging", "importlib-resources"]
[[package]]
category = "main"
description = "A very fast and expressive template engine."
marker = "extra == \"complete\""
name = "jinja2"
optional = false
python-versions = "*"
version = "2.10.3"
[package.dependencies]
MarkupSafe = ">=0.23"
[package.extras]
i18n = ["Babel (>=0.8)"]
[[package]]
category = "main"
description = "A fast implementation of the Cassowary constraint solver"
name = "kiwisolver"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "1.1.0"
[package.dependencies]
setuptools = "*"
[[package]]
category = "main"
description = "lightweight wrapper around basic LLVM functionality"
name = "llvmlite"
optional = false
python-versions = "*"
version = "0.30.0"
[[package]]
category = "main"
description = "File-based locks for Python for Linux and Windows"
marker = "extra == \"complete\""
name = "locket"
optional = false
python-versions = "*"
version = "0.2.0"
[[package]]
category = "main"
description = "Largest-Triangle-Three-Buckets algorithm for downsampling time series–like data"
name = "lttb"
optional = false
python-versions = ">=3.5"
version = "0.2.0"
[package.dependencies]
numpy = "*"
[[package]]
category = "main"
description = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
name = "lxml"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, != 3.4.*"
version = "4.4.1"
[package.extras]
cssselect = ["cssselect (>=0.7)"]
html5 = ["html5lib"]
htmlsoup = ["beautifulsoup4"]
source = ["Cython (>=0.29.7)"]
[[package]]
category = "main"
description = "Safely add untrusted strings to HTML/XML markup."
marker = "extra == \"complete\""
name = "markupsafe"
optional = false
python-versions = ">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*"
version = "1.1.1"
[[package]]
category = "main"
description = "Python plotting package"
name = "matplotlib"
optional = false
python-versions = ">=3.6"
version = "3.1.2"
[package.dependencies]
cycler = ">=0.10"
kiwisolver = ">=1.0.1"
numpy = ">=1.11"
pyparsing = ">=2.0.1,<2.0.4 || >2.0.4,<2.1.2 || >2.1.2,<2.1.6 || >2.1.6"
python-dateutil = ">=2.1"
[[package]]
category = "dev"
description = "McCabe checker, plugin for flake8"
name = "mccabe"
optional = false
python-versions = "*"
version = "0.6.1"
[[package]]
category = "main"
description = "An implementation of time.monotonic() for Python 2 & < 3.3"
name = "monotonic"
optional = false
python-versions = "*"
version = "1.5"
[[package]]
category = "dev"
description = "More routines for operating on iterables, beyond itertools"
name = "more-itertools"
optional = false
python-versions = ">=3.4"
version = "7.2.0"
[[package]]
category = "main"
description = "MessagePack (de)serializer."
marker = "extra == \"complete\""
name = "msgpack"
optional = false
python-versions = "*"
version = "0.6.2"
[[package]]
category = "main"
description = "compiling Python code using LLVM"
name = "numba"
optional = false
python-versions = "*"
version = "0.46.0"
[package.dependencies]
llvmlite = ">=0.30.0dev0"
numpy = "*"
[[package]]
category = "main"
description = "A Python package providing buffer compression and transformation codecs for use in data storage and communication applications."
name = "numcodecs"
optional = false
python-versions = "*"
version = "0.6.4"
[package.dependencies]
numpy = ">=1.7"
[package.extras]
msgpack = ["msgpack"]
[[package]]
category = "main"
description = "Fast numerical expression evaluator for NumPy"
name = "numexpr"
optional = false
python-versions = "*"
version = "2.7.0"
[package.dependencies]
numpy = ">=1.7"
[[package]]
category = "main"
description = "NumPy is the fundamental package for array computing with Python."
name = "numpy"
optional = false
python-versions = ">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*"
version = "1.16.5"
[[package]]
category = "main"
description = "Some add-ons to obspy"
name = "obsplus"
optional = false
python-versions = ">=3.6"
version = "0.0.3"
[package.dependencies]
black = "*"
cloudpickle = "*"
numpy = ">=1.13.0"
obspy = ">=1.1.0"
pandas = ">=0.23.3"
progressbar2 = "*"
scipy = "*"
tables = "*"
xarray = ">=0.10.9"
[package.extras]
docs = ["sphinx (>=1.5.1)", "ipykernel", "numpydoc", "sphinx-autodoc-typehints", "nbsphinx"]
[package.source]
reference = "f7ac7e426d985d1be94795e5037c7efd295a1447"
type = "git"
url = "https://github.com/niosh-mining/obsplus"
[[package]]
category = "main"
description = "ObsPy - a Python framework for seismological observatories."
name = "obspy"
optional = false
python-versions = "*"
version = "1.1.1"
[package.dependencies]
decorator = "*"
future = ">=0.12.4"
lxml = "*"
matplotlib = ">=1.1.0"
numpy = ">=1.6.1"
requests = "*"
scipy = ">=0.9.0"
setuptools = "*"
sqlalchemy = "*"
[package.extras]
arclink = ["cryptography"]
"io.shapefile" = ["pyshp"]
tests = ["flake8 (>=2)", "pyimgur", "pyproj", "pep8-naming", "mock"]
[[package]]
category = "main"
description = "Core utilities for Python packages"
marker = "extra == \"complete\""
name = "packaging"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "19.2"
[package.dependencies]
pyparsing = ">=2.0.2"
six = "*"
[[package]]
category = "main"
description = "Powerful data structures for data analysis, time series, and statistics"
name = "pandas"
optional = false
python-versions = ">=3.5.3"
version = "0.25.3"
[package.dependencies]
numpy = ">=1.13.3"
python-dateutil = ">=2.6.1"
pytz = ">=2017.2"
[package.extras]
test = ["pytest (>=4.0.2)", "pytest-xdist", "hypothesis (>=3.58)"]
[[package]]
category = "main"
description = "Appendable key-value storage"
marker = "extra == \"complete\""
name = "partd"
optional = false
python-versions = ">=3.5"
version = "1.1.0"
[package.dependencies]
locket = "*"
toolz = "*"
[package.extras]
complete = ["numpy (>=1.9.0)", "pandas (>=0.19.0)", "pyzmq", "blosc"]
[[package]]
category = "main"
description = "Utility library for gitignore style pattern matching of file paths."
name = "pathspec"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "0.6.0"
[[package]]
category = "main"
description = "Python Imaging Library (Fork)"
name = "pillow"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
version = "6.2.1"
[[package]]
category = "dev"
description = "plugin and hook calling mechanisms for python"
name = "pluggy"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "0.13.1"
[package.dependencies]
[package.dependencies.importlib-metadata]
python = "<3.8"
version = ">=0.12"
[package.extras]
dev = ["pre-commit", "tox"]
[[package]]
category = "main"
description = "A Python Progressbar library to provide visual (yet text based) progress to long running operations."
name = "progressbar2"
optional = false
python-versions = "*"
version = "3.47.0"
[package.dependencies]
python-utils = ">=2.3.0"
six = "*"
[package.extras]
docs = ["sphinx (>=1.7.4)"]
tests = ["flake8 (>=3.7.7)", "pytest (>=4.3.1)", "pytest-cov (>=2.6.1)", "pytest-flakes (>=4.0.0)", "pytest-pep8 (>=1.0.6)", "freezegun (>=0.3.11)", "sphinx (>=1.8.5)"]
[[package]]
category = "main"
description = "Cross-platform lib for process and system monitoring in Python."
marker = "extra == \"complete\""
name = "psutil"
optional = false
python-versions = ">=2.6, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "5.6.5"
[package.extras]
enum = ["enum34"]
[[package]]
category = "dev"
description = "library with cross-python path, ini-parsing, io, code, log facilities"
name = "py"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "1.8.0"
[[package]]
category = "main"
description = "Python library for Apache Arrow"
name = "pyarrow"
optional = false
python-versions = "*"
version = "0.15.1"
[package.dependencies]
numpy = ">=1.14"
six = ">=1.0.0"
[[package]]
category = "dev"
description = "Python style guide checker"
name = "pycodestyle"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "2.5.0"
[[package]]
category = "dev"
description = "passive checker of Python programs"
name = "pyflakes"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "2.1.1"
[[package]]
category = "main"
description = "Python parsing module"