Commit d4573d6b authored by Xuqian Yan's avatar Xuqian Yan
Browse files

Updated dependencies

parent cb86ce38
...@@ -19,6 +19,6 @@ formats: ...@@ -19,6 +19,6 @@ formats:
# Optionally set the version of Python and requirements required to build your docs # Optionally set the version of Python and requirements required to build your docs
python: python:
version: 3.7 version: 3.9
install: install:
- requirements: docs/requirements.txt - requirements: docs/requirements.txt
\ No newline at end of file
...@@ -8,4 +8,5 @@ sphinxcontrib-qthelp==1.0.2 ...@@ -8,4 +8,5 @@ sphinxcontrib-qthelp==1.0.2
sphinxcontrib-serializinghtml==1.1.3 sphinxcontrib-serializinghtml==1.1.3
sphinxcontrib-websupport==1.2.0 sphinxcontrib-websupport==1.2.0
sphinxemoji==0.1.6 sphinxemoji==0.1.6
sphinx-rtd-theme==0.5.0 sphinx-rtd-theme==0.5.0
\ No newline at end of file docutils==0.17
\ No newline at end of file
...@@ -6,6 +6,8 @@ How to compile the whole documentation locally: ...@@ -6,6 +6,8 @@ How to compile the whole documentation locally:
- conda create --name **nexuse-doc** (you can change the "nexuse-doc" to any name for the virtual environment) - conda create --name **nexuse-doc** (you can change the "nexuse-doc" to any name for the virtual environment)
- conda activate **nexuse-doc** - conda activate **nexuse-doc**
- cd to "docs" folder of this repository - cd to "docs" folder of this repository
- conda install python=3.9 (aligned with the python version specified in docs/.readthedocs.yml)
- conda install pip
- pip install -r "requirements.txt" - pip install -r "requirements.txt"
- make html - make html
- open build/html/index.html - open build/html/index.html
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment