Commit f58cd025 authored by Fabian's avatar Fabian
Browse files

Updated download instructions after a bit more of testing of what works and what not

parent e4b6f785
......@@ -64,8 +64,9 @@ Warning: The benchmarking runs signifcantly longer than the validation.
## On downloading it
You need access to Betl2. In this specific case, the submodule of NumPDE16 was
used. Even if you have access, you may encounter errors with gitlab not asking
for authentication when using HTTPS. These I have been able to avoid when
installing the repository as follows (`->` indicate changes that have to be made):
for authentication when using HTTPS or a connection time out when using SSH.
This should be resolved when installing the repository as follows (`->` indicate
changes that have to be made):
```
git clone https://gitlab.ethz.ch/hifabian/Code_DofHandler.git
......@@ -81,6 +82,12 @@ git submodule init
git submodule update
```
Or using the SSH in place of the HTTPS urls may also work.
Please do not do `git clone --recursive https://gitlab.ethz.ch/hifabian/Code_DofHandler.git
` or `git clone --recursive git@gitlab.ethz.ch:hifabian/Code_DofHandler.git`.
Betl2 provides a submodule that may not exist anymore and has to be changed.
If you have Betl2 but do not get the submodules working, you should be able to
just copy a Betl2 folder into `/Code_Dofhandler/` and it should work. However,
due to changes in Betl2 some files may throw errors. For example, the intersection
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment