To receive notifications about scheduled maintenance, please subscribe to the mailing-list gitlab-operations@sympa.ethz.ch. You can subscribe to the mailing-list at https://sympa.ethz.ch

Commit f9bda016 authored by beuchatp's avatar beuchatp
Browse files

Added some comments about installing QTM and getting python3 compatability

parent 1d185382
......@@ -6,9 +6,26 @@
# OR: #!/usr/bin/python3.5
# WHERE THE KEY INSTALLATIONS TO USE python3 ARE:
# sudo apt-get install python3-pip python3-yaml
# pip3 install rospkg catkin_pkg --user
# pip3 install qtm --user
# >> sudo apt-get install python3-pip python3-yaml
# >> pip3 install rospkg catkin_pkg --user
# INSTALL THE LATEST VERSION OF QTM
# >> pip3 install qtm --user
#
# OR
#
# For ubuntu 16.04, it is necessary to install an older version of QTM
# because of compatibility within Python 3.5.2 versus 3.5.3, the commit
# key from the GitHub repository is:
# qualisys_python_sdk-327bf90e2829e02c40d3d85ed11e6e4d2d25f8a8
#
# Once downloaded, this can be installed from file using:
# pip3 install -e /path/to/folder/where/setup.py/can/be/found
#
# Install also the requirements
# Note: that you need to remove "black==18.6b4" from the list
# in the "requirements.txt" file
# >> pip3 install -r /path/to/requirements.txt
# Copyright (C) 2019, ETH Zurich, D-ITET, Paul Beuchat
#
......@@ -279,9 +296,9 @@ class QualisysQtmClient:
this_crazyflie_data.occluded = False
# Fill in the position data
this_crazyflie_data.x = position.x
this_crazyflie_data.y = position.y
this_crazyflie_data.z = position.z
this_crazyflie_data.x = position.x * 0.001
this_crazyflie_data.y = position.y * 0.001
this_crazyflie_data.z = position.z * 0.001
# Fill in the position data
this_crazyflie_data.roll = rotation.a3 * DEG_TO_RAD
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment